ACM题目HangOver题意是什么How far can you make a stack of cards overhang a table?If you have one card,you can create a maximum overhang of half a card length.(We're assuming that the cards must be perpendicular to the table.) With two cards you

来源:学生作业帮助网 编辑:作业帮 时间:2024/11/20 11:46:49
ACM题目HangOver题意是什么How far can you make a stack of cards overhang a table?If you have one card,you can create a maximum overhang of half a card length.(We're assuming that the cards must be perpendicular to the table.) With two cards you
xUMo@+"Q\4Aꁢ^qz]7ܸV3TE fvGEAV7o߼Mg/}1Kt͏7?LC$,U 9@``,K.@33"/K%Bql0QT|EnD6aM5چWJMmm{ pBLhpY]%POE,J $pcwPC\H0$(gU+w#e\ӲcЏj@ K&*(}mse%ٚi7ETT69Bn9T(f)[(.mseL%eEeIaȡ+X$uf|έ,zAN`KiJ,s[ZXHL R6GN9+I{_j&/';C3M? kN}d@}Qt82co&L?U#+0:p ӣ=jR"?4dAe*↗֏*ȸ`Pj4ع٩~ՁA2q!&#.jrNiwB3|ӉR6XФک5~#wB;l4RK7) %

ACM题目HangOver题意是什么How far can you make a stack of cards overhang a table?If you have one card,you can create a maximum overhang of half a card length.(We're assuming that the cards must be perpendicular to the table.) With two cards you
ACM题目HangOver题意是什么
How far can you make a stack of cards overhang a table?If you have one card,you can create a maximum overhang of half a card length.(We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length,and the bottom one overhang the table by a third of a card length,for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths.In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ...+ 1/(n + 1) card lengths,where the top card overhangs the second by 1/2,the second overhangs tha third by 1/3,the third overhangs the fourth by 1/4,etc.,and the bottom card overhangs the table by 1/(n + 1).This is illustrated in the figure below.
The input consists of one or more test cases,followed by a line containing the number 0.00 that signals the end of the input.Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
For each test case,output the minimum number of cards necessary to achieve an overhang of at least c card lengths.Use the exact output format shown in the examples.
Sample Input:
1.00
3.71
0.04
5.19
0.00
Sample Output:
3 card(s)
61 card(s)
1 card(s)
273 card(s)

ACM题目HangOver题意是什么How far can you make a stack of cards overhang a table?If you have one card,you can create a maximum overhang of half a card length.(We're assuming that the cards must be perpendicular to the table.) With two cards you
# include
main()
{
int i;
float len,s;
while(1)
{
scanf("%f",&len);
s = 0.0;
if(0==len) break;
for(i = 2; ; i++)
{
s+=1.0/i;
if(s >= len)
break;
}
printf("%d card(s)\n",i-1);
}
return 0;
}